ENGL Imaging Toolkit™ 11.0.7 for ENGL Deployment

Project Wizard

After importing media into the File Library, a new project can be created or upgraded from a previous version of Imaging Toolkit. Projects contain the configuration and custom scripts necessary to create an automated Windows deployment process using Deployment Wizard.

The following project tasks can be performed.

Creating

The following are steps to create a new project.

  1. Select Tools>Options or in the global toolbar by clicking .
  2. Select Integration and then select the appropriate Desktop Management solution, then click OK.
  3. Do one of the following:

    Project Wizard opens.

  4. Click Next.
  5. Click the Desktop Management solution down arrow to display available Desktop Management Solution versions that can be used for your Windows deployment, then click Next.

    Note: To update the list of supported versions, exit the Project Wizard, select Help>Check for Updates then restart the Project Wizard.
  6. Click the Windows Operating System down arrow to display Windows media that has been imported and is compatible with the chosen Desktop Management Solution version, then click Next.

    Note: To import new Windows media select <New>.
  7. Complete the Windows Licensing details as follows:

  8. Complete the Windows Login Credentials details as follows:

  9. Click Next.
  10. Microsoft .NET Framework requirements are displayed.

    Note: The .NET Framework 4 media is required when the deployment operating system is Windows 7 or Server 2008 R2, otherwise the .NET Framework requirements page will not be displayed.

    Complete the .NET Framework requirements as follows:

  11. Active Directory configuration is displayed.

    Complete the Active Directory configuration as follows:

  12. Click Next.
  13. Project Details configuration is displayed.

    Complete the Project Details configuration as follows:

  14. Click Next.

    Finish page is displayed.
  15. Select Launch Deployment Wizard to start the Deployment Wizard after Finish is clicked.
  16. Click Finish.
  17. At the Project template must be saved to continue message box, click OK.
  18. Enter a target project path then click Save.

    Expert View will open.

Opening

The following are steps to open an existing project.

  1. Do one of the following:

    Project opens and Expert View appears.

    Note: If a previous Imaging Toolkit project is opened, a prompt may appear requesting confirmation before upgrading the project to Imaging Toolkit 11.0.7. Display of the upgrade prompt can be configured by selecting Tools>Options>General and changing the Prompt to Update Settings option. Custom task and phase strings will not be migrated from previous versions of Imaging Toolkit projects.


Customisation

The following are steps to customise an existing project using the Expert View.

  1. Do one of the following:

    Expert View is displayed.

  2. Select a category in the Expert View.

    Available settings will appear in the Properties view and Help will appear in the Help view.

    Note: To display the Help window select View>Help View.
  3. Modify settings in the Properties view.

    Note: Environment variables (values enclosed by % symbols, e.g. %COMPUTERNAME%) may be used for any property which takes a string value. The variables must be populated at the time of use. Non-existent variables will result in an empty string.

  4. Save the project.

Validating

The following are steps to validate an open project.

  1. Select Tools>Validate Project Settings or in the global toolbar click .
  2. Double-click each error displayed in the Errors view and resolve the issue then validate again.

Saving

The following are steps to save an open project.

  1. Do one of the following:

    Project is saved.

Closing

The following are steps to close an open project.

  1. Select File>Close.

    Project is closed.

Managing Projects

The following are steps to manage previously opened projects.

  1. Select Tools>Manage Projects.

    Manage Projects window is displayed.

    Note: Project files which could not be opened will appear as <Project could not be found>.
  2. Select one or more projects.
  3. Click Remove to delete the project and any custom files.
  4. Click Close.

    Manage Projects window is closed.